Joomla 2.5.3 problem with SEF Urls and com_contact

Please LogIn to Reply!

Post By: admin | 26-01-2012 06:35 Reply

Hi I have a website with Joomla 2.5.3.

I activated the friendly urls in Global configuration. (I've tried with and without "Use URL rewriting") And I'm sure that my .htaccess is working fine because all the links, but one, are working perfectly.

The problem is the com_contact link (404 error), I created a contact and a menu option for it. If I disable the SEF urls, it works, but with SEF urls all the other links work smoothly, only the contact for doesn't work.

I guess it is a 2.5 issue as the link to the form is Search/contact-us
Why is smart search on my url?
Does anyone know a solution for this problem.

Thanks in advance


Post By: | 09-20-2012 00:50

Good news,

Problem solved when upgrading from joomla 2.5.3 to 2.5.4

Post By: | 09-20-2012 00:50


I have the same problem of urls with the "blog category" view, in Joomla 2.5.3 :
the menu link is like that (with sef), and works well :
but the readmore links are like this :
and don't work !

When I disable SEF, everything is working... It seems to be a problem of SEFlink in Joomla 2.5.3.


NB : I haven't activate the smart search.

Post By: | 09-20-2012 00:50

I disable SEF and everything is working. I guess that is the only solution. Definitely a bad deal.

Post By: | 09-20-2012 00:50

I've been trying to find a solution for more than a week, but not success yet.

I tried disabling Smart Search, both, the plugin and the component. But still the same problem. Please if anybody knows anything about it, I would really appreciate the help.

I think the other options is avoid using SEF Urls until 2.5.4 is released, which is not good for my SEO, but what else can i do?

Post By: | 09-20-2012 00:50

I am having this problem with every menu item I create. When you click on the menu item, Smart Search ends up in the url and I get a 404 error. Just started with the 2.5.3 update. Was working fine before. I won't be updating my other Joomla sites without a resolution to this, that's for sure.

`Reply Or Comment!
Please LogIn to Reply!