Language Switcher Module displays but no languages shown

Please LogIn to Reply!

Post By: admin | 26-01-2012 06:35 Reply


I'm really hoping someone can help with this.

The problem I am facing is the following:
After installing Joomla 1.6.2 (I have also tried 1.6.3) I install a language es-ES (Spanish) full 1.6.3v1 and then enable the plugin "System - Language Filter" and then create a Language Switcher module.

The parameters I change for the Language Switcher module are the following:
Position: position-7 (Beez20 Template)
Status: Published
Use image flags: No
Pre-text: Joomla in your language

The Problem is that when I go to view the site, I can see the Language Switcher Module (Named Languages) there are no languages displayed, not even English(UK).

Am I right in thinking that even if I do not add an extra language that the LangSwitcher should at least display English(UK)?

What could I possibly be doing wrong? I have read your tutorials on creating multilingual sites and also watched some online tutorials and followed all of these exactly and still am facing this problem.
I have checked for errors using tools like Firefox Developer toolbar, Firebug and also have set Error Reporting to Maximum and no errors can be found.

Helllllp! :) :)

Thank you

EDIT: I just found the Forum Posting tool and run the diagnostics report. Please see below

JTS-post Diagnostic Information wrote:
Joomla! Version: Joomla! 1.6.2 Stable [ Onward ] 14-Apr-2011 23:00 GMT
configuration.php: Writable (Mode: 664 ) | Architecture/Platform: Linux 2.6.18-238.9.1.el5 ( x86_64) | Web Server: Apache/2.2.3 (CentOS) | PHP Version: 5.2.10
PHP Requirements: register_globals: Disabled | magic_quotes_gpc: Disabled | safe_mode: Disabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5 or above): No | iconv Support (1.5 or above): Yes | save.session_path: Writable | Max.Execution Time: 30 seconds | File Uploads: Enabled
MySQL Version: 5.0.77 ( Localhost via UNIX socket )

JTS-post Extended Information wrote:
SEF: Enabled (without ReWrite) | Legacy Mode: N/A | FTP Layer: N/A | htaccess: Not Implemented
PHP/suExec: User and Web Server accounts are not the same. (PHP/suExec probably not installed)
PHP Environment: API: apache2handler | MySQLi: Yes | Max. Memory: 32M | Max. Upload Size: 2M | Max. Post Size: 8M | Max. Input Time: 60 | Zend Version: 2.2.0
Disabled Functions:
MySQL Client: 5.0.77 ( latin1 )

Post By: | 09-20-2012 00:35

I have it completely working now. Thanks a lot!

The bad news: I am really wondering if this language switcher is what I'm looking for, since it reloads the page every time you switch language. In my website, where I want to do some programming procedures in the mean page as well, this could me very annoying.
Probably I have to program a language switcher my self that doesn't reload the whole page.. (?)
Thanks again!

Post By: | 09-20-2012 00:35

You may have not fully followed the tutorial.
Content languages have to be created. Menus for each language, default home pages for each language in these menus. The said languages must hane their language packs installed and publsihed, etc.

Post By: | 09-20-2012 00:35

Thanks a lot for your quick reply. Although I still didn't succeed. The steps seem a bit similar, and I don't see any flags or whatsoever for changing language. I did NOT jet make new templates per language, but i did try something with menu's per language. Module and plugin are switched on, but nothing is working.
Here is a screenshot: in between the load pre and load after and pre-text and post-text should be a nice switcher module...

Post By: | 09-20-2012 00:35

Post By: | 09-20-2012 00:35

I have more or less the same problem. I followed the guide, but I just don't see the switch language option. The module displays the a pre- and after text if I want, but there is just nothing in between.

I checked my version, installed languages, etc. etc. what I'm I doing wrong??
Thanks a lot!

Post By: | 09-20-2012 00:35

Please use 1.6.3 and read the Tutorial, step by step. ... Joomla_1.6

`Reply Or Comment!
Please LogIn to Reply!